Search found 912 matches

by AssumedPseudonym
Mon Mar 10, 2014 4:08 pm
Forum: Commonwealth
Topic: Intro demo ship criteria?
Replies: 13
Views: 2108

Re: Intro demo ship criteria?

 *…Blink. Blinkblink.* It is? *Roots around for old .zip file. Can’t find. Roots around for TransData download. Eventually finds. Downloads. Unzips.* Huh. How ’bout that. Thanks! …Well, I feel dumb, now…
by AssumedPseudonym
Mon Mar 10, 2014 6:07 am
Forum: Beta Bug Reports
Topic: [1.3b1] Engine effects sometimes spawn in with min size/col
Replies: 3
Views: 637

Re: [1.3b1] Engine effects sometimes spawn in with min size/

 Gating doesn’t seem to have any effect one way or another, but reloading the save appears to fix it.
by AssumedPseudonym
Mon Mar 10, 2014 12:39 am
Forum: Beta Bug Reports
Topic: [1.3b1] Engine effects sometimes spawn in with min size/col
Replies: 3
Views: 637

Re: [1.3b1] Engine effects sometimes spawn in with min size/

 It happens on playerships too, yeah. I had it happen to me on the Osaka.
by AssumedPseudonym
Mon Mar 10, 2014 12:24 am
Forum: Shipyards
Topic: Shipwrecks: (Ridiculously) minor graphics bug
Replies: 4
Views: 1288

Re: Shipwrecks: (Ridiculously) minor graphics bug

 Took a while, but if finally cropped up again. This actually happened in the 1.3 beta, but it was happening as far back as 1.1. I obviously had the Osaka expansion running, but neither of the mods I had active overwrite any of the vanilla graphics.
by AssumedPseudonym
Sun Mar 09, 2014 10:11 pm
Forum: Announcements
Topic: 1.3 Beta 1
Replies: 84
Views: 26023

Re: 1.3 Beta 1

 I made a copy the Sapphire to test with, just straight-up copypasta from the Playerships.xml and StdPlayerShips.xml files. <Armor armorID= "&itReactiveArmor;" count= "4" /> <PlayerSettings desc= "Test ship." largeImage= "&rsZubrinLarge;" initialClass= "true" startingCredits= "10d100+1500" > <ArmorD...
by AssumedPseudonym
Sun Mar 09, 2014 7:57 pm
Forum: Announcements
Topic: 1.3 Beta 1
Replies: 84
Views: 26023

Re: 1.3 Beta 1

  The playership is still registering hits from the wrong direction. Actually, that isn’t the problem. What’s happening is that the wrong armor segment is registering the hit. I’ve mucked about a bit to test it and I can get the right segment to register the hit, but none of the armor selection dock...
by AssumedPseudonym
Sun Mar 09, 2014 7:52 am
Forum: Mod Announcements
Topic: AE Mod Collection
Replies: 49
Views: 12522

AE Mod Collection

 Avian Enterprises, Inc. proudly presents five new playable ships, each uniquely different from each other and with features to set the apart from the vanilla playerships. The included README file details these. Balance suggestions are encouraged!  Also included: NPC versions of four of these ships,...
by AssumedPseudonym
Sun Mar 09, 2014 1:42 am
Forum: Beginner's Luck
Topic: Teratons not fabricating level 9+ equipment?
Replies: 10
Views: 1942

Re: Teratons not fabricating level 9+ equipment?

 I don’t remember the specifics, either, but I do recall from looking at the outdated wiki page and having done source-diving that they were nerfed. That happened in 1.1 at the latest. I’m pretty sure Level 7 is the cap for feeding it a weapon and getting back something higher level, so if you give ...
by AssumedPseudonym
Sat Mar 08, 2014 10:20 pm
Forum: Commonwealth
Topic: Intro demo ship criteria?
Replies: 13
Views: 2108

Re: Intro demo ship criteria?

It does it based on the various devices that it has. You can use TransData to display the computed score: TransData /shiptable /score  Thanks again. That explains why some of the ships that showed up in 1.1’s demo don’t show up in 1.2’s (the Ares Sentry comes to mind). I’d used TransData to decompi...
by AssumedPseudonym
Sat Mar 08, 2014 7:15 pm
Forum: Commonwealth
Topic: Intro demo ship criteria?
Replies: 13
Views: 2108

Re: Intro demo ship criteria?

 Ah-ha, that suddenly makes a lot more sense. Thanks! It does bring up a secondary question, though. For ships that don’t have a score set (which is approximately all of them as of 1.2), how does the game calculate a ship’s score?
by AssumedPseudonym
Sat Mar 08, 2014 8:12 am
Forum: Commonwealth
Topic: Intro demo ship criteria?
Replies: 13
Views: 2108

Re: Intro demo ship criteria?

 I have that for my playerships, yes, but I mean even the NPCs, be they vanilla, expansion, or mod.  And just to make sure we’re not crossing wires, here, I’m referring to the demo, before you even get to the ship selection screen to start a new game or load an existing one. There are some ships tha...
by AssumedPseudonym
Sat Mar 08, 2014 2:21 am
Forum: Commonwealth
Topic: Intro demo ship criteria?
Replies: 13
Views: 2108

Intro demo ship criteria?

 Okay, I have no idea where to ask this one, so I’m tossing it here: What are the criteria necessary for making a ship show up in the demo when you first launch the game? I’ve noticed that there are some a lot that never turn up randomly without going through the list to find them, even in just stra...
by AssumedPseudonym
Thu Mar 06, 2014 9:21 pm
Forum: Shipyards
Topic: Shipwrecks: (Ridiculously) minor graphics bug
Replies: 4
Views: 1288

Re: Shipwrecks: (Ridiculously) minor graphics bug

 I’ll get a screenshot the next time it happens. It’s pretty rare. The code is fairly straightforward, though: <?xml version="1.0" ?> <!DOCTYPE TranscendenceExtension [ <!ENTITY unidExtension "0xDCC80007"> ]> <TranscendenceExtension UNID="0xDCC80007;" version="1.1" name="Avian Enterprises - Substitu...
by AssumedPseudonym
Tue Mar 04, 2014 11:50 am
Forum: Beta Bug Reports
Topic: Hits registering on playership from wrong direction
Replies: 3
Views: 896

Re: Hits registering on playership from wrong direction

 I’ve isolated part of where the problem is coming from. In 1.2, armor is declared using: <Armor armorID="&itXMHArmor;" count="4"/>  In 1.1, armor was declared using: <Armor> <ArmorSection start="315" span="90" armorID="&itXMHArmor;" areaSet="0,2" /> <ArmorSection start="225" span="90" armorID="&itX...
by AssumedPseudonym
Tue Mar 04, 2014 7:46 am
Forum: Beta Bug Reports
Topic: Hits registering on playership from wrong direction
Replies: 3
Views: 896

Hits registering on playership from wrong direction

 I tested this one on all three vanilla playerships after noticing something strange while doing graphics checks for a mod playership of mine. I checked the Osaka, too, for good measure. In each case, the only hits showing as coming from the right direction were from the front. Shots hitting the sta...