Sound overrides in libraries don't unload properly

Bug reports for the stable versions go here.
Post Reply
User avatar
Shrike
Fleet Admiral
Fleet Admiral
Posts: 2618
Joined: Mon Aug 17, 2009 4:27 am
Location: Scouting the borders of sanity (there's a lovely view of the abyss).

Sound overrides in libraries don't unload properly

Post by Shrike » Fri Sep 19, 2014 1:51 am

I'm running the current version of TSB, which over-rides snArmorHit1 to be slightly more annoying than was previously the case. Unfortunately, regardless of whether or not I have TSB enabled, the library is still over-writing the sound and causing me to feel like killing my speakers. Apparently this isn't a TSB thing (I haven't seen the code, but Wolfy took a look at it). I suspect that libraries are not being selected correctly when starting a new game, and it's possible for code in an "unselected" library to alter a game.
Your friendly local genderqueer weapons designer & forum moderator. My pronoun is "They".

Image
Shrike's Mines and Missiles++. Includes parts of the old Auton Overhaul and Allegedly Superior Sounds mods as well as an updated version of the MOTM-winning SM&M! Designed for Version 1.6.3

User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5340
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

Re: Sound overrides in libraries don't unload properly

Post by Wolfy » Sat Sep 20, 2014 4:59 am

BTW I just directly overwrote the base sound resource


There is an underlying problem though, that we need better sound mixing to avoid massive overlap.
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest