[Closed] Help reproducing this bug

These are old bug reports that have been closed.
Locked
george moromisato
Developer
Developer
Posts: 2877
Joined: Thu Jul 24, 2003 9:53 pm
Contact:

Mon May 09, 2011 11:05 pm

I need help reproducing this bug: http://wiki.neurohack.com/transcendence/trac/ticket/340

Basically, it says that the CSC Antarctica doesn't fire on the player. I've followed these steps:

1. Go to the Dantalion system (usually via Elyssium)
2. Go to the Commonwealth station and pay 10,000 rin to get the location of the Antarctica
3. Go to the Antarctica and open fire.
4. For each shot, the Antarctica says, "Cease fire..."
5. At some point, it turns red.
6. Then it immediately starts attacking me (using its TeV9s and missiles).

The bug says that #6 doesn't happen (although it does turn red). Can anyone reproduce?

A few clues:

a. There is code in the engine that prevents secondary weapons from attacking non-aggressive ships, where non-aggressive is defined as "has not fired a weapon in some period of time." Since the Antarctica's TeV9s count as secondary weapons, they will not attack the player if he/she hasn't fired.

b. Perhaps if wingmen attack the Antarctica without the player then this will repro.

c. In a nebula, it is possible that the Antarctica cannot see the player (though I don't know the range).

If you get a reproducible case, can you please save a copy of the game and send to me ([email protected])? Thanks!

User avatar
sdw195
Militia Captain
Militia Captain
Posts: 779
Joined: Wed Nov 18, 2009 1:01 am
Location: Still looking for the csc Antarctica
Contact:

Tue May 10, 2011 12:08 am

just did it,

steps

1 go to Dantalion system (via g.o.d mod)
2 get IM90
3 fly around the gates till you find it
4 open fire
5 watch as it runs away helplessly
Image
Image
Image
Image
"Dash_Merc - George is a genius, in that he created this game engine that is infinitely extendable"
"<@sheepluva>Good night everybody, may the source be with you." <-- FOSG dev
"You only need THREE tools in life - WD-40 to make things go, Duct Tape to make things stop And C-4 to make things go away"

User avatar
Ttech
Fleet Admiral
Fleet Admiral
Posts: 2750
Joined: Tue Nov 06, 2007 12:03 am
Location: Traveling in the TARDIS
Contact:

Tue May 10, 2011 12:10 am

humm. Sounds more like a feature to me. :roll:
But seriously though, I just tried it but I wasn't able to get this to happen. I went to the system fired on Antartica but it never turned red.
Image
Image

*** AWAY ON SABBATICAL ***
** USE EMAIL TO CONTACT ME **

Amilir
Militia Lieutenant
Militia Lieutenant
Posts: 151
Joined: Fri Feb 12, 2010 4:56 pm
Location: With the stRong.

Tue May 10, 2011 2:54 am

Honestly, I'm having more trouble getting the Antarctica to attack me.

george moromisato
Developer
Developer
Posts: 2877
Joined: Thu Jul 24, 2003 9:53 pm
Contact:

Tue May 10, 2011 4:36 am

Thank you all. RPC sent me a save file that helped me to debug the problem.

It turned out to be an uninitialized variable bug that only appeared in Release mode (not on Debug builds, which is why I couldn't find it). Under certain circumstances, particularly with ships with lots of secondary weapons, the engine failed to find any targets. This is fixed in 1.06.

Thanks all!

Locked