[1.2b3] Random crash on game load/game exit

These are old bug reports that have been closed.
Locked
User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5389
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

Thu Oct 10, 2013 4:40 am

I'm seemingly randomly getting crash errors on loading a saved game, or exiting transcendence. The latter doesnt matter too much, but the former is slightly annoying. However, I can load it up again, and it will work just fine. Seems to occur about 30% of the time. This is with the following mods installed:

TSB Alpha Test Extension & Libraries
DSF (alterecco)
G.O.D.Mod (alterecco)
Test Extension & its library (just a demo mod I made for people on irc yesterday on 'how to use libraries')
LRL15
Corporate command (and its library)

It didnt seem to do this with no mods installed.
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Homelab Servers: Xeon Silver 4110, 16GB | Via Quadcore C4650, 16GB | Athlon 200GE, 8GB | i7 7800X, 32GB | Threadripper 1950X, 32GB | Atom x5 8350, 4GB | Opteron 8174, 16GB
Workstations & Render machines: Threadripper 2990WX, 32GB, 2x 1080ti | Xeon Platinum 8173M, 48GB, 1070ti | R9 3900X, 16GB, Vega64 | 2x E5 2430L v2, 24GB, 970
Office Systems: 2x Xeon Silver 4116, 96GB, 2x 1080ti | i7 3770, 16GB, some old quadro | i5 3210m, 8GB | some i7 macbook
Misc Systems: R5 3500U, 20GB | R5 2400G, 16GB | i5 7640X, 16GB, Vega56 | E5 2620, 8GB, R5 260 | P4 1.8ghz, 0.75GB, Voodoo 5 5500 | Athlon 64 x2 4400+, 1.5GB, FX 5800 Ultra | Pentium D 3.2ghz, 4GB, 7600gt | Celeron g460, 8GB, 730gt | 2x Athlon FX 74, 8GB, 8800gts 512 | FX 9590, 16GB, R9 295x2 | E350, 8GB | Phenom X4 2.6ghz, 16GB, 8800gt | random core2 duo/atom/i5/i7 laptops

george moromisato
Developer
Developer
Posts: 2979
Joined: Thu Jul 24, 2003 9:53 pm
Contact:

Thu Oct 10, 2013 4:45 am

I believe I've figured this out. CFG was also getting these crashes and I think I've been able to fix them in the next beta (real soon now...)

User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5389
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

Thu Oct 10, 2013 7:42 am

Thats good - but just a bit earlier..

I found what seems to be a related but much more critical error:

Sometimes, when transcendence exits, it closes the window but the game continues spinning the CPUs in the background. After enough failed closes, eventually all the CPUs on the machine will be spinning. In this case I had half of them spinning, but was going to render some promotional art for TSB quickly (can't though, turns out I'm missing some texture files since I reinstalled windows.. need to find them), and 3dsmax ended up trying to use all the cores, which caused the system run out of cores to execute on (hexcore system) and it nosedived. Eventually managed to get taskmanager open and kill the processes but that could qualify as an OS-killing bug.

This happens about 1/8th of the time.
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Homelab Servers: Xeon Silver 4110, 16GB | Via Quadcore C4650, 16GB | Athlon 200GE, 8GB | i7 7800X, 32GB | Threadripper 1950X, 32GB | Atom x5 8350, 4GB | Opteron 8174, 16GB
Workstations & Render machines: Threadripper 2990WX, 32GB, 2x 1080ti | Xeon Platinum 8173M, 48GB, 1070ti | R9 3900X, 16GB, Vega64 | 2x E5 2430L v2, 24GB, 970
Office Systems: 2x Xeon Silver 4116, 96GB, 2x 1080ti | i7 3770, 16GB, some old quadro | i5 3210m, 8GB | some i7 macbook
Misc Systems: R5 3500U, 20GB | R5 2400G, 16GB | i5 7640X, 16GB, Vega56 | E5 2620, 8GB, R5 260 | P4 1.8ghz, 0.75GB, Voodoo 5 5500 | Athlon 64 x2 4400+, 1.5GB, FX 5800 Ultra | Pentium D 3.2ghz, 4GB, 7600gt | Celeron g460, 8GB, 730gt | 2x Athlon FX 74, 8GB, 8800gts 512 | FX 9590, 16GB, R9 295x2 | E350, 8GB | Phenom X4 2.6ghz, 16GB, 8800gt | random core2 duo/atom/i5/i7 laptops

Locked