getAPIversion and apiversions

Freeform discussion about anything related to modding Transcendence.
Post Reply
User avatar
digdug
Fleet Admiral
Fleet Admiral
Posts: 2601
Joined: Mon Oct 29, 2007 9:23 pm
Location: Decoding hieroglyphics on Tan-Ru-Dorem

Fri Apr 14, 2017 3:06 pm

I'm trying to use getAPIversion in a mod (specifically in the functionlist function) to return the APIversion of the game, so that it will be printed nicely at the top of the functionlist.

I'm having some problems with this: getAPIversion returns the API version that the game engine is running in that game session.
For example, you have a mod of APIversion 27, it will return 27, even if you are running transcendence 1.7, which is APIversion 35. (just discovered that version 1.1 is actually APIversion 3, lol, and yes, that's how old is the functionlist function last time I updated it)


This is great to check compatibility between mods, less so for what I wanted it to do. :P

Moreover, if you are trying to circumvent this, and use a future APIversion, let's say 50, the game will load fine, but it won't allow you to load the mod when you start the game, asking you to use an updated version. :) APIversion -1 have the same problem. APIversion 0 won't allow the game to load. (Unable to load extension: incompatible version: 0)

Post Reply