Manticore shield penalty

Bug reports for the stable versions go here.
Post Reply
Shaman
Commonwealth Pilot
Commonwealth Pilot
Posts: 95
Joined: Fri Sep 20, 2013 2:03 pm

I have a Mammoth 25MW and enhanced it in St. Katharine. After the enhancement(kinetic), the -20% penalty was no longer displayed in neither the HUD or Ship Configuration. It's still active, just the -20% is not displayed.

In the same Game the Esc-key stopped working entirely, I couldn't even use it in windows. A reboot solved the problem. I'm not sure if this has something do to with the game, just wanted to mention it.
User avatar
Song
Fleet Admiral
Fleet Admiral
Posts: 2771
Joined: Mon Aug 17, 2009 4:27 am

The former is down to a limitation in how the game displays enhancements.....it'll only show one at a time. This is probably because it was originally designed for only single-source enhancements....whereas nowadays it's common to have enhancements/penalties from multiple sources (in the case of the manticore the ship itself provides the penalty, and the enhancement is on the shield).

Never seen the latter before, but I've seen similar things happen in other games before on Windows.
Mischievous local moderator. She/Her pronouns.
User avatar
sun1404
Militia Captain
Militia Captain
Posts: 527
Joined: Thu Nov 03, 2011 10:32 am
Location: Heretic. (Finally!)

In my case, sometimes the Esc and other keys doesn't work because, somehow, the language got changed. I'm not sure why would language affect Esc, but it did many times before on my machine. Next time try changing your language and hit Esc again, a few times. Maybe you'll have to wait a little(2-3 seconds) after changing the language. :D
Yes, look at my avatar, I have a wyvera type ship.
Shaman
Commonwealth Pilot
Commonwealth Pilot
Posts: 95
Joined: Fri Sep 20, 2013 2:03 pm

You mean by altering the keyboard-language? I tried that intentionally and the key worked fine. I can't reproduce the bug this way, but thanks anyway. If this happens again, I will try your method.
Maybe your Keyboard changes to a unusual language? Mine is standard german, which is very close to the english layout.

Regarding the display of the shield penalty, this occured:
I used the shield rom on another shield. The penalty was countered and now it's showing +0.
Not really a bug, but I think +0 shouldn't be displayed.
User avatar
sun1404
Militia Captain
Militia Captain
Posts: 527
Joined: Thu Nov 03, 2011 10:32 am
Location: Heretic. (Finally!)

I use English-Thai keyboard, but still it shouldn't do anything to the Esc key.
Yes, look at my avatar, I have a wyvera type ship.
Post Reply