1.08c

New releases and announcements from George and the staff.
george moromisato
Developer
Developer
Posts: 2995
Joined: Thu Jul 24, 2003 9:53 pm
Contact:

1.08c is ready for download in the usual place:

http://www.neurohack.com/downloads/Trans108c.zip
http://www.neurohack.com/downloads/TransData26.zip

This release has the following new features:

1. Library support.
http://neurohack.com/transcendence/foru ... f=5&t=5194

2. Lots of bug fixes and enhancements requested by modders.
http://wiki.neurohack.com/transcendence/trac/report/14

3. Initial implementation of automatic download of mods from Multiverse. This is still in progress (there is nothing on the Multiverse to download!)

4. Automatic crash reporting to the Multiverse.

5. An embryonic Multiverse is taking shape at:
http://multiverse.kronosaur.com/index.hexm

In particular, the high-scores have moved to:
http://multiverse.kronosaur.com/games.hexm

One cautionary note: There have been lots of internal changes in this release, particularly with regards to extensions, so please test your extensions to make sure that they still work. If not, please file bugs (anything that worked in 1.08b but break in 1.08c is a candidate; similarly, please report anything that worked on 1.01 but breaks in 1.08c.)
User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5402
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

:D Thanks george! Now I can resume work on TSB (got halted over a few issues.)

I'll test out 1.08b and 1.05TSB (1.05 having been the one that was causing unid errors in 1.08b)
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Homelab Servers: Xeon Silver 4110, 16GB | Via Quadcore C4650, 16GB | Athlon 200GE, 8GB | i7 7800X, 32GB | Threadripper 1950X, 32GB | Atom x5 8350, 4GB | Opteron 8174, 16GB | Xeon E5 2620 v3, 8GB
Workstations & Render machines: Threadripper 3990X, 128GB, 1080ti | Threadripper 2990WX, 32GB, 1080ti | Xeon Platinum 8173M, 48GB, 1070ti | R9 3900X, 16GB, Vega64 | 2x E5 2430L v2, 24GB, 970
Office Systems: 2x Xeon Silver 4116, 96GB, 2x 1080ti | i7 3770, 16GB, some old quadro | i5 3210m, 8GB | some i7 macbook
Misc Systems: R5 3500U, 20GB | R5 2400G, 16GB | i5 7640X, 16GB, Vega56 | E5 2620, 8GB, R5 260 | P4 1.8ghz, 0.75GB, Voodoo 5 5500 | Athlon 64 x2 4400+, 1.5GB, FX 5800 Ultra | Pentium D 3.2ghz, 4GB, 7600gt | Celeron g460, 8GB, 730gt | 2x Athlon FX 74, 8GB, 8800gts 512 | FX 9590, 16GB, R9 295x2 | E350, 8GB | Phenom X4 2.6ghz, 16GB, 8800gt | random core2 duo/atom/i5/i7 laptops
User avatar
digdug
Fleet Admiral
Fleet Admiral
Posts: 2619
Joined: Mon Oct 29, 2007 9:23 pm
Location: Decoding hieroglyphics on Tan-Ru-Dorem

Thanks George ! :D
User avatar
Song
Fleet Admiral
Fleet Admiral
Posts: 2778
Joined: Mon Aug 17, 2009 4:27 am

I've just downloaded, and I don't seem to be hearing any sounds when I fire weapons.

Edit: before anyone asks, yes, my sound is turned on. The music plays fine, but weapons sounds (and possibly hiteffect sounds) do not.

Edit2: I tested this with Elemental Shift, SM&M+ and GOD/DSF installed for starters, and sound failed. I then removed the extensions folder entirely, and the problem continued.
Last edited by Song on Thu Jul 12, 2012 10:10 pm, edited 1 time in total.
Mischievous local moderator. She/Her pronouns.
RPC
Fleet Admiral
Fleet Admiral
Posts: 2876
Joined: Thu Feb 03, 2011 5:21 am
Location: Hmm... I'm confused. Anybody have a starmap to the Core?

w00t! Now for with TypCreate! :D
Tutorial List on the Wiki and Installing Mods
Get on Discord for mod help and general chat
Image
Image
Der Tod ist der zeitlose Frieden und das leben ist der Krieg
Wir müssen wissen — wir werden wissen!
I don't want any sort of copyright on my Transcendence mods. Feel free to take/modify whatever you want.
PM
Fleet Admiral
Fleet Admiral
Posts: 2566
Joined: Wed Sep 01, 2010 12:54 am

Shrike wrote:I've just downloaded, and I don't seem to be hearing any sounds when I fire weapons.
Same here. No sound at all except for the music (if on).
Download and Play in 1.9 beta 1...
Drake Technologies (Alpha): More hardware for combat in parts 1 and 2!
Star Castle Arcade: Play a classic arcade game adventure, with or without more features (like powerups)!
Playership Drones: Buy or restore exotic ships to command!

Other playable mods from 1.8 and 1.7, waiting to be updated...
Godmode v3 (WIP): Dev/cheat tool compatible with D&O parts 1 or 2.
User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5402
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

Yep, I can confirm that neither modded nor vanilla in-game sound effects are playing regardless of volume setting.
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Homelab Servers: Xeon Silver 4110, 16GB | Via Quadcore C4650, 16GB | Athlon 200GE, 8GB | i7 7800X, 32GB | Threadripper 1950X, 32GB | Atom x5 8350, 4GB | Opteron 8174, 16GB | Xeon E5 2620 v3, 8GB
Workstations & Render machines: Threadripper 3990X, 128GB, 1080ti | Threadripper 2990WX, 32GB, 1080ti | Xeon Platinum 8173M, 48GB, 1070ti | R9 3900X, 16GB, Vega64 | 2x E5 2430L v2, 24GB, 970
Office Systems: 2x Xeon Silver 4116, 96GB, 2x 1080ti | i7 3770, 16GB, some old quadro | i5 3210m, 8GB | some i7 macbook
Misc Systems: R5 3500U, 20GB | R5 2400G, 16GB | i5 7640X, 16GB, Vega56 | E5 2620, 8GB, R5 260 | P4 1.8ghz, 0.75GB, Voodoo 5 5500 | Athlon 64 x2 4400+, 1.5GB, FX 5800 Ultra | Pentium D 3.2ghz, 4GB, 7600gt | Celeron g460, 8GB, 730gt | 2x Athlon FX 74, 8GB, 8800gts 512 | FX 9590, 16GB, R9 295x2 | E350, 8GB | Phenom X4 2.6ghz, 16GB, 8800gt | random core2 duo/atom/i5/i7 laptops
User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5402
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

I was also looking at the koronosaur site, and RPC says the login works, but for me it just hangs. I thought it was just a placeholder, but apparently its bugged. I am using Firefox 14.0 beta 2
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Homelab Servers: Xeon Silver 4110, 16GB | Via Quadcore C4650, 16GB | Athlon 200GE, 8GB | i7 7800X, 32GB | Threadripper 1950X, 32GB | Atom x5 8350, 4GB | Opteron 8174, 16GB | Xeon E5 2620 v3, 8GB
Workstations & Render machines: Threadripper 3990X, 128GB, 1080ti | Threadripper 2990WX, 32GB, 1080ti | Xeon Platinum 8173M, 48GB, 1070ti | R9 3900X, 16GB, Vega64 | 2x E5 2430L v2, 24GB, 970
Office Systems: 2x Xeon Silver 4116, 96GB, 2x 1080ti | i7 3770, 16GB, some old quadro | i5 3210m, 8GB | some i7 macbook
Misc Systems: R5 3500U, 20GB | R5 2400G, 16GB | i5 7640X, 16GB, Vega56 | E5 2620, 8GB, R5 260 | P4 1.8ghz, 0.75GB, Voodoo 5 5500 | Athlon 64 x2 4400+, 1.5GB, FX 5800 Ultra | Pentium D 3.2ghz, 4GB, 7600gt | Celeron g460, 8GB, 730gt | 2x Athlon FX 74, 8GB, 8800gts 512 | FX 9590, 16GB, R9 295x2 | E350, 8GB | Phenom X4 2.6ghz, 16GB, 8800gt | random core2 duo/atom/i5/i7 laptops
george moromisato
Developer
Developer
Posts: 2995
Joined: Thu Jul 24, 2003 9:53 pm
Contact:

PM wrote:
Shrike wrote:I've just downloaded, and I don't seem to be hearing any sounds when I fire weapons.
Same here. No sound at all except for the music (if on).
Oops. Yeah, I found a problem in loading sound file from TDBs. I'll do a quick fix.

Thanks!
george moromisato
Developer
Developer
Posts: 2995
Joined: Thu Jul 24, 2003 9:53 pm
Contact:

Wolfy wrote:I was also looking at the koronosaur site, and RPC says the login works, but for me it just hangs. I thought it was just a placeholder, but apparently its bugged. I am using Firefox 14.0 beta 2
Definitely bugged. I've only tried in Chrome, and I suspect that there is some bug preventing it from working on Firefox. Definitely does not work in IE.
User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5402
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

On the sound issue; it wasn't working for me with TSB sounds which were not in the TDB; ie, I had a playership that started with a weapon with a custom sound that wasn't making any sound - does it somehow fix loading for extension sounds as well?

EDIT- were you replacing the 1.08c download or adding a new one for the sound issue?
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Homelab Servers: Xeon Silver 4110, 16GB | Via Quadcore C4650, 16GB | Athlon 200GE, 8GB | i7 7800X, 32GB | Threadripper 1950X, 32GB | Atom x5 8350, 4GB | Opteron 8174, 16GB | Xeon E5 2620 v3, 8GB
Workstations & Render machines: Threadripper 3990X, 128GB, 1080ti | Threadripper 2990WX, 32GB, 1080ti | Xeon Platinum 8173M, 48GB, 1070ti | R9 3900X, 16GB, Vega64 | 2x E5 2430L v2, 24GB, 970
Office Systems: 2x Xeon Silver 4116, 96GB, 2x 1080ti | i7 3770, 16GB, some old quadro | i5 3210m, 8GB | some i7 macbook
Misc Systems: R5 3500U, 20GB | R5 2400G, 16GB | i5 7640X, 16GB, Vega56 | E5 2620, 8GB, R5 260 | P4 1.8ghz, 0.75GB, Voodoo 5 5500 | Athlon 64 x2 4400+, 1.5GB, FX 5800 Ultra | Pentium D 3.2ghz, 4GB, 7600gt | Celeron g460, 8GB, 730gt | 2x Athlon FX 74, 8GB, 8800gts 512 | FX 9590, 16GB, R9 295x2 | E350, 8GB | Phenom X4 2.6ghz, 16GB, 8800gt | random core2 duo/atom/i5/i7 laptops
george moromisato
Developer
Developer
Posts: 2995
Joined: Thu Jul 24, 2003 9:53 pm
Contact:

BTW: Use caution when logging in to the Multiverse. Right now, during beta testing, passwords are sent up to the web site in the clear. This means that someone spying on your network would be able to get your password. There's not much on the Multiverse right now, so it's no big deal, as long as you don't use the same password on other sites.

The site uses a cookie to store an auth-token so you don't have to sign in every time. The auth-token DOES NOT contain your password, so it is safe to use, even in a public place (for now).

Best practice is to sign in to the Multiverse at home (in a safe network) and rely on the cookie everywhere else. Even better would be to use a unique password for the Multiverse.
george moromisato
Developer
Developer
Posts: 2995
Joined: Thu Jul 24, 2003 9:53 pm
Contact:

Wolfy wrote:On the sound issue; it wasn't working for me with TSB sounds which were not in the TDB; ie, I had a playership that started with a weapon with a custom sound that wasn't making any sound - does it somehow fix loading for extension sounds as well?

EDIT- were you replacing the 1.08c download or adding a new one for the sound issue?
You're right. The fix should cover XML files also.

I was thinking of releasing a new build (1.08d) to fix the problem. Seems like the best way to track it. I will release a new build today or tomorrow (I'll wait 12 hours or so to see if any other killer bugs appear).
User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5402
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

Ok, I updated a whole lot of things on the trac (some related to 1.08c's release, others related to my on-going project to organize the trac)

Trac changes:

New components:
Community Sites <-- for issues with the trac, wiki, forums; this is mainly for me to check so that I can get quickly appraised of any problems or tasks pertinent to the trac/wiki/forum. Anything requiring george to fix would be deferred to him
Multiverse <-- for issues with the Multiverse; this is intended for george

New versions:
1.08c (default)
1.08d (for tomorrow)

New milestones:
1.08d
Non-Issues <-- a place to dump all the invalid/worksforme/won'tfix tickets that are sitting around in 0.0 Not Scheduled; I already moved all the 'fixed' tickets out of there and into their correct milestones
Community Sites <-- for tickets with the community sites component
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Homelab Servers: Xeon Silver 4110, 16GB | Via Quadcore C4650, 16GB | Athlon 200GE, 8GB | i7 7800X, 32GB | Threadripper 1950X, 32GB | Atom x5 8350, 4GB | Opteron 8174, 16GB | Xeon E5 2620 v3, 8GB
Workstations & Render machines: Threadripper 3990X, 128GB, 1080ti | Threadripper 2990WX, 32GB, 1080ti | Xeon Platinum 8173M, 48GB, 1070ti | R9 3900X, 16GB, Vega64 | 2x E5 2430L v2, 24GB, 970
Office Systems: 2x Xeon Silver 4116, 96GB, 2x 1080ti | i7 3770, 16GB, some old quadro | i5 3210m, 8GB | some i7 macbook
Misc Systems: R5 3500U, 20GB | R5 2400G, 16GB | i5 7640X, 16GB, Vega56 | E5 2620, 8GB, R5 260 | P4 1.8ghz, 0.75GB, Voodoo 5 5500 | Athlon 64 x2 4400+, 1.5GB, FX 5800 Ultra | Pentium D 3.2ghz, 4GB, 7600gt | Celeron g460, 8GB, 730gt | 2x Athlon FX 74, 8GB, 8800gts 512 | FX 9590, 16GB, R9 295x2 | E350, 8GB | Phenom X4 2.6ghz, 16GB, 8800gt | random core2 duo/atom/i5/i7 laptops
User avatar
Wolfy
Fleet Admiral
Fleet Admiral
Posts: 5402
Joined: Tue Feb 05, 2008 1:10 am
Location: Somewhere in the Frontier on a Hycrotan station, working on new ships.

I also ended up adding milestones for the 3 new 1.08 versions that george is planning (1.08e, 1.08f, 1.08g)

Also here is a general announcement to the community/task ticket for myself regarding the trac organization http://wiki.neurohack.com/transcendence/trac/ticket/990
(shpOrder gPlayership 'barrelRoll)
(plySetGenome gPlayer (list 'hycrotan 'nonBinary))
Image
Homelab Servers: Xeon Silver 4110, 16GB | Via Quadcore C4650, 16GB | Athlon 200GE, 8GB | i7 7800X, 32GB | Threadripper 1950X, 32GB | Atom x5 8350, 4GB | Opteron 8174, 16GB | Xeon E5 2620 v3, 8GB
Workstations & Render machines: Threadripper 3990X, 128GB, 1080ti | Threadripper 2990WX, 32GB, 1080ti | Xeon Platinum 8173M, 48GB, 1070ti | R9 3900X, 16GB, Vega64 | 2x E5 2430L v2, 24GB, 970
Office Systems: 2x Xeon Silver 4116, 96GB, 2x 1080ti | i7 3770, 16GB, some old quadro | i5 3210m, 8GB | some i7 macbook
Misc Systems: R5 3500U, 20GB | R5 2400G, 16GB | i5 7640X, 16GB, Vega56 | E5 2620, 8GB, R5 260 | P4 1.8ghz, 0.75GB, Voodoo 5 5500 | Athlon 64 x2 4400+, 1.5GB, FX 5800 Ultra | Pentium D 3.2ghz, 4GB, 7600gt | Celeron g460, 8GB, 730gt | 2x Athlon FX 74, 8GB, 8800gts 512 | FX 9590, 16GB, R9 295x2 | E350, 8GB | Phenom X4 2.6ghz, 16GB, 8800gt | random core2 duo/atom/i5/i7 laptops
Post Reply